Karya Inovasi

Enam Karya Inovasi Teknik Komputer Dan Jaringan - Automatic Water Plant System - Smart Home Dengan Rasberry 3 B+ - LED CUBE 4 x 4 Arduino - Light With Bluetooth Arduino - Mesin Penetas Telur Digital - Dispenser Electrics

Saturday, April 29, 2017

cara install windows 7 lite via virtual box-materiUPK2017

     beberapa saat lagi UPK kejuruan TKJ akan di langsungkan,materi UPK meliputi:

  1. perakitan komputer
  2. installasi sistem operasi komputer(windows 7)
  3. membuat kabel straight
            nah, pada kesempatan ini kami akan memberikan salah satu materi UPK yaitu install windows 7.
berikut langkah-langkahnya :
Daftar Isi
  1. Persiapan
  2. Pembuatan Mesin Virtual Windows 7
  3. Instalasi Mesin Virtual Windows 7
  4. Permasalahan Instalasi (Troubleshooting)


1. Persiapan
Untuk membuat mesin virtual Windows 7 dengan VirtualBox, diperlukan hal-hal berikut:



2. Pembuatan Mesin Virtual Windows 7
Jalankan aplikasi VirtualBox untuk memulai pembuatan mesin virtual baru.



Tekan tombol "New" atau pilih menu Machine, kemudian item New untuk membuat guest machine baruShortcut Ctrl-N (tekan tombol fungsi kontrol bersamaan dengan menekan huruf N pada keyboard) juga dapat digunakan untuk pembuatan mesin virtual baru.
Selanjutnya muncul jendela pop-up Create Virtual Machine, yang berguna untuk label dan jenis serta versi sistem operasi guest yang akan diinstall.
Pada isian Name, tulis nama sistem operasi guest yang akan diinstall, dalam hal ini adalah Windows 7. Nama sistem operasi guest juga digunakan sebagai nama folder untuk lokasi file sistem operasi guest (pada Windows 7 lokasi default folder mesin virtual adalah C:\Users\Account-Login\VirtualBox VMs). Pada bagian Type, pilih Windows 7 dan di bagian Version, sesuaikan versi Windows 7 yang akan diinstall, apakah versi 32-bit atau versi 64-bit. Selanjutnya tekan tombol Next.


Layar selanjutnya pengaturan jumlah memori yang akan dialokasikan untuk mesin virtual dalam satuan Megabyte. Secara otomatis, VirtualBox akan memberikan saran alokasi memori untuk sistem operasi Windows 7 yang akan diinstall adalah 192 MB.


Jika ingin melakukan perubahan, isian maksimal ditunjukan oleh indikator warna hijau atau setengah dari total jumlah memori komputer yang tersedia, agar sistem operasi utama tidak menjadi terganggu. Selanjutnya tekan tombol Next.


Bagian selanjutnya adalah pengaturan media penyimpanan (hard disk) yang akan digunakan mesin virtual Windows 7. VirtualBox memberikan rekomendasi kapasitas hard disk virtual yang akan dibuat berdasarkan jenis sistem operasi yang ditentukan sebelumnya. Kapasitas hard disk yang disarankan tersebut dapat kita ganti sesuai kebutuhan kita.
Dalam pengaturan hard disk virtual, tersedia 3 (tiga) opsi yang dapat digunakan:

  • Do not add a virtual hard drive
    Opsi ini digunakan untuk pengguna tingkat mahir, karena hard disk virtual akan dibuat dalam pengaturan terpisah dan setelah pembuatan mesin virtual Windows 7 selesai dilakukan.
  • Create a virtual hard drive now
    Opsi ini digunakan untuk membuat hard disk virtual baru bersamaan dengan pembuatan mesin virtual Windows 7.
  • Use an existing virtual hard drive
    Gunakan opsi ini untuk memilih hard disk virtual yang sudah ada.
Pilih opsi Create a virtual hard drive now karena kita akan langsung membuat hard disk virtual untuk mesin virtual Windows 7. Kemudian tekan tombol Create.


Layar selanjutnya untuk menentukan jenis (ekstensi) file hard disk virtual yang akan dibuat. Standarnya VirtualBox menggunakan format file VDI (VirtualBox Disk Image) untuk penyimpanan hard disk virtual.
VirtualBox juga mendukung pembacaan jenis file dari aplikasi-aplikasi virtual lainnya, seperti VMDK (Virtual Machine Disk) yang merupakan format dari aplikasi virtual Vmware, VHD (Virtual Hard Disk) format dari Microsoft Virtual PC, HDD (Parallels Hard Disk) format aplikasi virtual dari Parallels atau format dari aplikasi virtual QEMU.


Setelah menekan tombol Next, pengaturan selanjutnya untuk menentukan "bagaimana" hard disk virtual yang akan dibuat tersebut disimpan pada hard disk fisik (hard disk host).
Di bagian ini tersedia 2 (dua) opsi yang dapat dipilih:

  • Dynamically allocated,
    Artinya kapasitas hard disk fisik akan digunakan berdasarkan berapa kapasitas hard disk virtual sudah terpakai dan tidak berdasarkan berapa ukuran hard disk virtual ditentukan. Kapasitas hard disk virtual akan dibatasi berdasarkan ukuran yang telah ditentukan.
  • Fixed size,
    Artinya kapasitas hard disk fisik akan digunakan berdasarkan ukuran kapasitas hard disk virtual dibuat, walaupun kapasitas hard disk virtual tersebut masih kosong atau belum digunakan.
Disarankan untuk memilih opsi Dynamically allocated, kemudian tekan tombol Next.


Layar selanjutnya berguna untuk menentukan nama tampil dan nama folder tempat menyimpan file-file mesin virtual yang akan kita buat. Kita juga dapat menempatkan file-file mesin virtual ke dalam folder atau direktori yang sudah ada, atau pada hard disk lain yang berbeda dengan hard disk yang digunakan oleh sistem operasi utama.


Di layar ini, kita juga dapat merubah kapasitas hard disk virtual yang akan dibuat sesuai dengan kebutuhan kita. Jika dalam langkah ke-6 kita memilih opsi Dynamically allocated, maka kita dapat membuat ukuran hard disk virtual sampai 2 Terabyte, walaupun hard disk fisik (utama) kita tidak mencapai ukuran 2 Terabyte. Namun, jika kapasitas hard disk fisik kita dibawah 2 Terabyte, tentunya kapasitas hard disk virtual yang dapat digunakan maksimal kapasitas hard disk fisik yang tersisa.


Tekan tombol Create untuk membuat mesin virtual Windows 7 berdasarkan pengaturan yang telah dilakukan.
Selesai proses tersebut, di bagian kiri layar aplikasi VirtualBox, akan ditampilkan sebuah mesin virtual Windows 7 dalam keadaan kosong dan siap untuk diinstall.

3. Install Mesin Virtual Windows 7
Langkah selanjutnya adalah melakukan instalasi pada mesin virtual Windows 7 yang kita buat. Klik ganda pada mesin virtual Windows 7 atau klik tombol Start (icon panah) untuk menjalankan mesin virtual Windows 7.
Dikarenakan mesin virtual yang kita jalankan belum memiliki sistem operasi, secara otomatis VirtualBox akan menampilkan kotak dialog yang berguna untuk memilih disk drive yang berfungsi sebagai start-up.


Klik icon di bagian kanan untuk memilih master Windows 7.


Pilih master sistem operasi yang akan digunakan. Format file master sistem operasi dapat dalam bentuk iso, cdr atau dmg. Klik ganda pada file master Windows 7 atau klik tombol Open untuk menutup pop-up pemilihan file dan kembali ke layar sebelumnya.


Setelah itu, klik tombol Start untuk memulai proses instalasi mesin virtual Windows 7.

tonton vidio tutorial install windows 7 di sini




Cara Setting Router di CISCO sebagai gateway internet

Untuk memudahkan dalam mempraktikkan Gateway Internet pada Router Cisco hendaknya kita berpatokan pada Gambar Topologi Jaringan di bawah ini.

Topologi Jaringan Setting Router Cisco sebagai Gateway Internet

Keterangan:

  1. PC Admin, berfungsi melakukan setting Router Cisco melalui port Console menggunakan Hyper Terminal
  2. PC Client, berfungsi menguji akses Internet saat Router Cisco telah selesai disetting sebagai Gateway Internet.
  3. fa0/0, IP Publik, contoh: 76.54.32.2/30
  4. fa0/1, IP Private, contoh: 192.168.0.1/24
  5. IP Address ISP, 76.54.32.1


Di bawah ini diuraikan Cara setting Router Cisco sebagai Gateway Internet Berdasarkan 2 (dua) tahap tersebut.

A. Setting/Konfigurasi Koneksi Router ke Internet


Sebelumnya pastikan masuk ke Privileged Exec Mode (Administrator / root), dengan cara:
Router>enable

A. 1. Setting/konfigurasi IP Address


Setting IP Address fa0/0
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip address 76.54.32.2 255.255.255.252
Router(config-if)#no shutdown

Setting IP Address fa0/1
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no shutdown

Cek apakah Interface telah memiliki IP Address dan dalam keadaan aktif, dengan perintah:
Router#show ip interface brief
Interface        IP-Address    OK? Method Status Protocol
FastEthernet0/0  76.54.32.2    YES manual   up      up
FastEthernet0/1  192.168.0.1   YES manual   up      up


A. 2. Setting Default Gateway ke ISP


Melakukan setting Default Gateway berfungsi agar Router Cisco dapat melakukan terhubung (ping) ke IP Publik yang lain yang ada di Internet.

Router(config)#ip route 0.0.0.0 0.0.0.0 76.54.32.1

Untuk memeriksa apakah Default Gateway telah tersetting dengan benar, gunakan perintah:
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 76.54.32.1 to network 0.0.0.0

     76.54.32.0/30 is subnetted, 1 subnets
C    76.54.32.0 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [1/0] via 76.54.32.1

A. 3. Setting DNS Resolver


Agar Router Cisco dapat melakukan koneksi (ping) ke Hostname atau nama domain yang ada di Internet, maka perlu disetting DNS Resolver dengan cara:

Router(config)#ip name-server 76.54.32.1


B. Setting/Konfigurasi NAT (Network Address Translation)


Konfigurasi NAT (Masquerade) berfungsi agar jaringan LAN dapat terhubung ke Internet melalui Router Cisco. Maka dari itu, Router Cisco harus disetting untuk melakukan NAT (Masquerade) untuk network 192.168.0.0/24. Caranya adalah sebagai berikut.

Router(config)#access-list 1 permit 192.168.0.0 0.0.0.255
Router(config)#ip nat inside source list 1 interface f0/0 overload
Router(config)#interface f0/0
Router(config-if)#ip nat outside
Router(config-if)#interface f0/1
Router(config-if)#ip nat inside

Sampai disini, beberapa PC Client yang ada pada Jaringan LAN akan dapat mengakses Internet melalui Router Cisco yang telah dikonfigurasi sebagai Gateway Internet.

Konfigurasi DHCP (Opsional)


Langkah ini opsional yang berfungsi memberikan IP Address otomatis kepada PC Client. Perintah yang digunakan adalah sebagai berikut.

Router(config)#ip dhcp excluded-address 192.168.0.2 192.168.0.10
Router(config)#ip dhcp pool LAN-POOL-1
Router(dhcp-config)#network 192.168.0.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.0.1
Router(dhcp-config)#dns-server 76.54.32.1
Router(dhcp-config)#exit 

IP Address 192.168.0.2 sampai dengan 192.168.0.10 adalah IP Address yang tidak akan diberikan kepada PC Client pada LAN.

TKJ

TKJ yang merupakan singkatan dari Teknik Komputer dan Jaringan adalah salah satu jurusan yang tersedia di tingkat SMK. Jurusan ini berada di dalam Bidang Studi Teknologi Informasi dan Komunikasi dan di bawah Program Studi Teknik Komputer dan Informatika.

Jurusan TKJ termasuk jurusan yang sangat populer di SMK, baik dari SMK Negeri maupun Swasta banyak yang membuka jurusan ini. Apalagi di wilayah Pekalongan, SMK yang membuka Jurusan TKJ juga banyak jumlahnya.

Jurusan TKJ membutuhkan alat dan bahan yang tidak sedikit dan tidak murah. Beberapa perangkat seperti komputer desktop merupakan alat yang wajib ada di jurusan TKJ, beberapa sekolah bahkan telah menyediakan laptop/netbook untuk mengakomodir kegiatan pratikum perakitan komputer. Alat-alat yang lain yang juga dibutuhkan untuk jurusan TKJ adalah periperal tambahan seperti Printer, Scanner, Webcam, Speaker, Headset, Bluetooth, Converter Interface, dll. Kemudian perangkat jaringan juga mutlak diperlukan seperti Hub/Switch, Router, Wireless Access Point, Wireless Router, Antenna Wireless, Wireless Client, Modem USB, Modem ADSL.
Jika mau mengikuti standar dunia kerja / dunia industri skala nasional/internasional maka sekolah harus menyediakan perangkat tersebut dengan level Enterprise (kelas perusahaan besar). Misalnya mengadakan perangkat jaringan Router atau Switch Enterprise yang bermerk Cisco. Jika sekolah ingin benar-benar mengajarkan jaringan WAN yang dipakai oleh penyedia jaringan Internet (seperti: Telkom, Indosat, dll) maka perangkat yang harus disediakan juga tidak kalah mahal seperti: DSLAM yang harga termurahnya sekitar 20 jutaan, kemudian perangkat BTS, Switch dan Router dengan banyak Interface yang mendukung WAN.



Apa saja yang diajarkan pada Jurusan TKJ?

Yang diajarkan pada Jurusan TKJ antara lain seperti:

Perakitan Komputer.
Bongkar pasang komputer baik jenis desktop, laptop, maupun netbook. Tidak semua sekolah mengajarkan perakitan laptop / netbook karena kendala biaya pengadaan.


Sistem Operasi, baik berbasis Windows maupun Unix-like seperti Linux dan variannya.
Diajarkan bagaimana menginstalasi Sistem Operasi untuk berbagai jenis komputer baik desktop, laptop, maupun netbook.
Beberapa sekolah bahkan mengajarkan instalasi sistem operasi Android di komputer yang berbasis x86.

Jaringan Dasar dan jaringan lanjutan.
Membangun komunikasi antar komputer maupun komputer dengan perangkat lainnya seperti Switch, Router, Wireless Access Point, dll.

Pemrograman Dasar
Mengajarkan algoritma dan alur pemrograman dari dasar. Diajarkan pula membuat program komputer sederhana.

Pemrograman Web
Mengajarkan pembuatan Website, maupun aplikasi berbasis web. Secara teknis mengajarkan siswa memahami dan mempraktikkan HTML, CSS, Javascript, PHP dan MySQL untuk membuat Website maupun aplikasi berbasis Web.

Jaringan Wireless
Membangun jaringan komputer tanpa kabel yang menghubungkan komputer, dengan perangkat lainnya seperti laptop, netbook, tablet, dll

Server
Membangun sistem yang dapat memberikan layanan kepada komputer lain, seperti mail servis, web, DNS, VoIP, FTP Servis, Cloud Computing, dll.

Desain Grafis
Mengajarkan pembuatan karya desain yang dapat digunakan pada industri cetak maupun grafis untuk tampilan pada layar.

Animasi
Mengajarkan pembuatan animasi sederhana, untuk TKJ biasanya hanya berupa animasi 2D saja.


Komputer Terapan
Mempelajari sistem komputer terkini yang berhubungan dengan teknologi mobile computing maupun robotic computing. Jenis komputer yang dipelajari seperti raspberry, arduino, atau alix. Belum semua SMK mempelajari ini karena keterbatasan alat dan kemampuan Guru pengajar.

Cara Mengatasi Blue Screen of Death pada Windows 10

Kemunculan Windows 10 ternyata diwarnai dengan beberapa masalah atau bug. Bahkan, PC sampai menunjukkan tampilan Blue Screen of Death atau biasa disingkat dengan BSOD.
Dilansir Ibtimes, Minggu (2/8/2015), beberapa pengguna Windows 10 dilaporkan mengalami kasus Blue Screen of Death (BSOD) error C1900101-20017 selama instalasi Windows 10.
BSOD mengakibatkan PC tiba-tiba melakukan restart atau reboot. Pengguna mendapatkan pesan BSOD yang muncul setelah PC perlu untuk melakukan restart selama upgrade Windows 10.
Kemudian, PC kembali restart, menampilkan pesan error dengan kode C1900101-20017. Tampilan teks di pesan tersebut menunjukkan bahwa installer gagal dalam fase SAFE_OS selama proses boot.
Dilaporkan bahwa isu ini muncul karena pengaturan BIOS yang salah. Masalah BSOD ini bisa diperbaiki dengan langkah sederhana, yakni dengan mengaktifkan UEFI Boot dari BIOS dan menon-aktifkan semua opsi overclocking untuk prosesor.
Untuk langkah lebih rinci, pengguna bisa mengikuti langkah sebagai berikut.
Pertama, pengguna bisa menuju C: > Windows > Software Distribution > Download dan hapus semua file yang tersimpan dalam folder.
Hapus juga $Windows.~BT folder yang berada di direktori 'C'.
Pengguna dapat melakukan clean install Windows 10 menggunakan file ISO Windows 10 dari website resmi Microsoft.
Setelah mengunduh file ISO, pengguna perlu untuk menciptakan bootable installation media melalui Media Creation tool Microsoft.
Dengan demikian, pengguna menyiapkan drive USB atau DVD untuk proses bootable dan dapat mengakses beberapa pengaturan di menu BIOS.
Kemudian reboot, setelah itu pengguna bisa menekan tombol F12 atau tombol delete untuk masuk ke menu BIOS.
Pada tampilan menu BIOS, pengguna bisa menghilangkan opsi overclocking untuk prosesor.
Setelah itu, pengguna disarankan untuk mengaktifkan UEFI Boot dari BIOS, yang dapat ditemukan di bawah Boot section dari layar BIOS.
Kemudian, pengguna melakukan reboot PC dan masuk ke proses instalasi Windows 10 dari media instalasi yang dibuat oleh pengguna (USB atau DVD).
Diharapkan setelah menerapkan langkah ini, pengguna tidak akan lagi menemukan gangguan BSOD.

Sejarah Lambang @ pada email

Email (Electronic Mail) atau Surat Elektronik (surel) dikirimkan pertama kali oleh seorang Programmer Komputer bernama Ray Tomlinson pada Oktober 1971. Nah. dialah juga yang mencetuskan penggunaan tanda @ untuk memisahkan nama pemakai dengan alamatnya. Tanda @ yang jenius itu ia pikirkan hanya dalam hitungan 30 sampai 40 detik.

"Aku memainkan jari-jariku di keyboard untuk menemukan simbol yang tidak dipakai untuk nama manusia dan bukan merupakan angka. Hanya tanda itulah yang paling tepat." Ceritanya tentang penemuannya yang sangat berpengaruh pada komunikasi modern itu.

Tomlinson adalah lulusan MIT tahun 1965. Tanda @ ditemukan saat Tomlinson bekerja di perusahaan komputer Bolt Beranek and Newman (BBN). Serupa para penemu di abad informasi, misalnya Tim Berners-Lee yang menemukan Internet, Tomlinson tidak mematenkan penemuannya.

Source: Tabloid Fantasi Teen Edisi 595 Tahun XII

Sunday, April 16, 2017

Thursday, April 13, 2017

pelaksanaan ujian praktek kejuruan